読者です 読者をやめる 読者になる 読者になる

Miyakawa Blog

ウェブディレクターが日々のことを綴るブログ

Sass のち Compass ときどき Norton

Retina MacBook Pro 13 に買い替えておよそ 2, 3週間程度です。WEB 開発の環境を整えようと Sublime Text 2 や Node.js、Homebrew、RubyGems、Sass や Compass などを入れる作業中、なぜか Sass と Compass だけが入らずズット悩んでました。

正確にいうと RubyGems のコマンドに頼ってる Sass と Compass だけが通らなかったんですが・・・

何をしてもだめ。

例えば、ターミナルで「sudo gem install sass」としても、次の通り。

ERROR: Could not find a valid gem 'sass' (>= 0), here is why:
Unable to download data from https://rubygems.org/ - Errno::ENOMEM: Cannot allocate memory - connect(2) (https://rubygems.org/latest_specs.4.8.gz)
Sass が見つからなかったよ。理由は RubyGems に接続できなかったからだよ。

みたいに言われてました。

ビジネスプランコンテストの準備などでバタバタしていたので、開発の仕事はしばらくしていなかったからそのままにしていました。

今日久しぶりに時間ができたので試してみますが、改善されているわけもなく。 「・・・・・あっ、ビジネスプランコンテストの準備中に Keynote と Keynote Remote の接続がトラブったときに Norton がファイアウォールでせき止めてたけど、まさか!?」 と、早速、Nortorn をオフって試してみました。

すると、、、万事解決しました。

ハハハハッ (^^;;

Sass も Compass も無事インストールできましたw

Norton なんて、 Norton なんてキライだーw

覚え書き

Mac ターミナルコマンドの覚え書き

RubyGems のアップデート

sudo gem update --system

Sass のインストール

sudo gem install sass

Sass のバージョン確認

sass -v

Compass のインストール

sudo gem install compass

Compass のバージョン確認

compass -v